[공지] v1 '사용자 정보 요청' API 종료 / [Deprecation Notice] 'Requesting user information's version 1 API

v1 ‘사용자 정보 요청’ API가 서비스 종료됩니다.
보다 풍부한 정보를 제공하는 v2 ‘사용자 정보 요청’ API가 지난 2018년 5월부터 제공되고 있으며,
기존의 v1 ‘사용자 정보 요청’ API는 다음 일정에 따라 서비스 종료됩니다.

  • 1차 : 2020년 2월 10일
  • 2차 : 2020년 8월 10일 (1차 종료일 이전에 v2 '사용자 정보 요청’을 적용한 서비스에 한정)

v1 ‘사용자 정보 요청’ API 서비스 종료 후, 해당 API를 호출하면 에러 응답을 받게 됩니다.
따라서 v2 ‘사용자 정보 요청’ API를 사용하도록 업데이트해야 합니다.

Step 1. v1 ‘사용자 정보 요청’ API 사용 여부 확인

  • iOS SDK: v1.15.0 이하의 SDK를 사용하는 경우, v1.8.0 이상은 deprecated 경고 메시지 발생

  • Android SDK: v1.22.0 이하의 SDK를 사용하는 경우, v1.11.0 이상은 deprecated 경고 메시지 발생

  • JavaScript SDK: Kakao.API.request 함수의 url 속성 값이 '/v1/user/me’인 경우 또는 Kakao.Auth.getStatus 사용하는 경우

  • REST API: 사용 중인 사용자 정보 요청 Request URI가 '/v1/user/me’인 경우

Step 2. v2 ‘사용자 정보 요청’ API로 업데이트

  • iOS SDK:

    • v1.8.0 미만: SDK v1 최신 버전으로 업데이트 (2월 26일 기준 1.21.0)
    • v1.8.0 이상 v1.15.0 미만 : v1 me 메소드(KOSessionTask.meTask) 사용하지 않도록 변경
    • v1.15.0 이상: 해당 없음
  • Android SDK:

    • v1.11.0 미만: SDK v1 최신 버전으로 업데이트 (2월 26일 기준 1.27.0)
    • v1.11.0 이상 v1.22.0 미만 : v1 me 메소드(UserManagement.getInstance().requestMe) 사용하지 않도록 변경
    • v1.22.0 이상: 해당 없음
  • JavaScript SDK:

    • Kakao.API.request 함수를 사용한 '사용자 정보 요청’의 url 속성 값을 '/v2/user/me’로 변경
    • Kakao.Auth.getStatus -> Kakao.Auth.getStatusInfo로 변경
  • REST API:

    • 사용자 정보 요청 Request URI를 '/v2/user/me’로 변경

참고: v2 ‘사용자 정보 요청 API’ 가이드

==================================================================

[Deprecation Notice] 'Requesting user information’s version 1 API

To provide a better API with abundant information, we have started to provide 'Requesting user information’s version 2 API since May 2018. And the 'Requesting user information’s version 1 API is deprecated as of the following dates:

· 1st effective date: February 10, 2020 (has deprecated as of February 18, 2020)
· 2nd effective date: Agust 10, 2020 (only for the services adopting 'Requesting user information’s version 2 before the 1st effective date.)


You should update your code IF:

  • iOS SDK: you use SDK version 1.10.5 or less or you get a warning message related to deprecation.
  • Android SDK: you use SDK version 1.22.0 or less or you get a warning message related to deprecation.
  • JavaScript SDK: the URI value of Kakao.API.request function is set to /v1/user/me or Kakao.Auth.getStatus is used.
  • REST API: you set /v1/user/me as the request URI.

How to update:

iOS SDK:

  • lower than v 1.8.0: Update the SDK v1 to the latest version(1.22.0 as of March 18, 2020)
  • v 1.8.0 or higher / lower than v.15.0: Update not to use the KOSessionTask.meTask method.
  • v 1.15.0 or higher: No need to change

Android SDK:

  • lower than v1.11.0: Update the SDK v1 to the latest version(1.28.0 as of March 18, 2020).
  • v 1.11.0 or higher / lower than v.22.0: Update not to use the UserManagement.getInstance().requestMe method.
  • v 1.22.0 or higher: No need to change

JavaScript SDK:

  • Change the value of URI in Requesting user information API using the Kakao.API.request function to /v2/user/me.
  • Change Kakao.Auth.getStatus to Kakao.Auth.getStatusInfo.

REST API:

  • Change the Request URI of Requesting user information API from /v1/user/me to /v2/user/me.

Reference: the guides about requesting user information v2

좋아요 1
사용자정보요청 v1, v2 관련 문의드립니다
로그인 sdk v2.0 2월 10일까지 적용 못할 경우
Api 2차 종료일까지 버전 변경이 가능한지 궁금합니다
V1 사용자정보 요청 API 종료관련 deprecated 메소드 문의드립니다
/user/me 의 응답의 여러가지 id 대한 문의
기존 v1 프로필요청 API가 어떻게 바뀐건가요?
아아.......v1 사용자 정보 종료....우째야 합니까....ㅠㅠㅠㅠㅠ
카카오 로그인 오류
카카오 로그인 갑자기 안되네요
카카오로 로그인 시 오류납니다
카카오로그인이 2월 18일부터 되지 않습니다
기준에 사용중이던 카카오 로그인이 안됩니다
카카오 로그인 오류 문의
Ios 카카오톡 로그인이 갑자기 안됩니다
Api 연동 문제 로그인 관련하여
카카오 계정으로 로그인 시 '동의하고 계속하기' 이후로 진행이 안됩니다
Rest api에러 메세지
카카오로그인 v2 서포트라이브러리 가능한 버전이 몇부터인지 문의드립니다
카카오로그인 서비스장애
유니티2020 에디터에서 카카오SDK 로그인 시 System.Collections.Generic.KeyNotFoundException
로그인 연결 test하는데 동의 항목 설정창이 안떠요
가비아 홈페이지 - 카카오 간편로그인 연동 불가
Https://kapi.kakao.com/v1/user/me 404로 인하여 정상적인 로그인 처리가 불가능 합니다
Kakao login api에서 404 / not-found 가 나옵니다
Kakao sdk를 사용하도록 도와주세요
V1 ‘사용자 정보 요청’ API 서비스 종료 대응 문의
사용자 프로필 요청이 실패
카카오톡 로그인 관련 질문
로그인시 -32099 에러 발생
친구 api 사용 신청합니다
사용자관리 api 실행에서 오류 문의드립니다
/v1/user/me 에러 관련 질문입니다
카카오 간편로그인 api 호출관련
카카오톡 회원가입 및 로그인 할 때 오류가 발생합니다
카카오 로그인 에러

2020년 2월 7일에 v2 ‘사용자 정보 요청’ API로 전환하지 않은 서비스를 대상으로 리마이드 공지 메일이 발송되었고,
잊고 있던 서비스들에게 시간을 주기 위해,
기존 일정인 2월 10일이 아닌 오늘(2월 18일)에 1차 종료 하였습니다.

2차 종료는 리마인드 공지 메일 없이 예정대로 8/10 월요일에 진행됩니다.

좋아요 1

2020-08-10 11:54 에 2차 종료 완료되었습니다.