[카카오톡 공유] 첨부 이미지 형식 제한

  • 카카오톡 공유에서는 다음과 같이 이미지의 크기 및 용량에 제한을 두고 있습니다. 아래의 제한을 넘기면 이미지가 표시되지 않을 수 있습니다.
보여질 크기의 경우 최소 가로(width) 80px, 세로(height) 80px이므로 이보다 크게 설정하여야 합니다. 또한 이미지 용량은 500kb이하로 제한 됩니다.

참고토픽: [카카오톡 공유] 웹링크 이미지 크기가 클 경우 [카카오톡 공유] 첨부되는 이미지(url) 형식에 제한이 있나요?

  • 현재 카카오링크로 보낼 수 있는 이미지 URL은 서버에 존재하는 이미지뿐, 로컬 기기에 있는 이미지는 지원되지 않습니다.

참고토픽: [카카오톡 공유] 로컬 이미지를 별도의 이미지 서버 없이 공유할 수 있나요?

  • 하나의 사진이 하나의 url을 가지도록하는것이 보장이 되어야 합니다. 카카오톡 내부적으로 url로 이미지를 캐싱하고 있기 때문에 같은 URL에 맵핑된 이미지를 변경한다고 해도 전송되는 이미지는 같습니다.

참고토픽: [카카오톡 공유] 같은 URL로 맵핑된 이미지를 변경하여도 반영이 되지 않습니다.

  • 카카오톡 공유에서는 RFC2396, RFC1034, RFC1123 를 준수 하지 않는 이미지 url은 이미지가 보이지 않습니다.
2개의 좋아요
카카오톡 이미지 관련
카카오톡링크 이미지 크기
[카카오 링크] 첨부되는 이미지(url) 형식에 제한이 있나요?
[카카오링크] 이미지전송 시 파일형태로 전송은 안되나요?
[카카오링크] 클라이언트의 카카오링크 addImage에서 설정한 url은 유지한채 url에 해당하는 이미지 파일을 변경하였는데, 변경이 되지 않습니다
[카카오링크] 카카오 링크 이미지 교체
[카카오링크] 웹링크 이미지 크기가 클 경우
createTalkLinkButton 이미지 크기는 반드시 입력해야 하는지?
카카오 링크 이미지 캐싱 문의
공유하기 4019 에러
카카오톡 공유 템플릿 검증 응답에 다른 앱(네이티브 키)의 실행 스킴·마켓 URL이 내려오는 문제
앱 > 앱 설정 > 앱 > 제품 링크 관리 , 도메인 변경 실시간 반영 문의
[카카오톡 공유] 모바일에서만 KAPIError(4002) 지속 발생 — 문서상 원인 3가지 모두 확인/조치 완료
카카오톡 공유 — PC 웹 피커는 정상, 모바일에서만 KAPIError(4002) 발생
카카오톡 공유하기시 4019 오류
카카오톡 공유 기능 앱 링크 관련 문의
카카오톡 공유하기 다른 앱 스키마를 사용하는 방법
카카오톡 공유하기 앱 미실행 이슈
[급]카카오톡 공유 시 에러코드 5001
Faq 목록 입니다
365Quiz 도형 퀴즈 웹서비스의 카카오톡 공유 API 사용 가능 여부 문의
[카카오링크] 로컬 이미지를 별도의 이미지 서버 없이 공유할 수 있나요?
공유하기 하단 아이콘 링크 문의
카카오톡 URL 메타 정보 관리 이미지 교체 안됩니다
앱 ID 1623422 정책 위반 안내 및 오류 코드 4020 관련 문의
카카오톡 공유하기 4019 오류 - 도메인 등록했는데 같은 JS 키가 간헐적으로 domain mismatched (앱 ID 1611125)
[앱 1604683] 웹훅 테스트는 성공하지만 실제 카카오톡 공유 웹훅 미수신
카카오톡 공유하기(sendScrap) 호출 시 간헐적 4011 오류 발생 문의
카카오톡 공유 웹훅이 전혀 발송되지 않습니다 (테스트 도구·외부 수신기에도 미도착, 앱 ID 1590572 / 1606260)
Kakao.Share.sendScrap 모바일 4002: CSP 연결 차단 여부 확인 (앱 ID 1361058)
카카오톡 공유하기 오류
카카오톡 공유(sendDefault) 4011 "잘못되었거나 삭제된 앱 키" — 등록 정보 모두 일치하는데도 반복 재현
Google Apps Script에서 Kakao.Share.sendDefault() 호출 시 4019 오류 문의
앱 (웹훅) 데이터를 불러오지 못했습니다
디버거 관련: 채팅창에서 url 입력시 수정된 OG 정보가 업데이트되지 않습니다
avaScript SDK sendDefault commerce 템플릿에서 content.description 및 fixedDiscountPrice가 표시되지 않습니다
카카오 공유하기가 간헐적으로 안됩니다