[공지/Notice] iOS 앱을 위한 개인정보 보호 목록(Privacy Manifest) 지원 안내 / We support Privacy Manifest for iOS apps

안녕하세요, 카카오입니다.

Apple이 오는 2024년 5월 1일부터 "사용 이유를 명시해야 하는 API(Required reason API)"를 사용하는 앱이나 SDK는 개인정보 보호 목록(Privacy Manifest)에 API 사용 이유를 명시하도록 하는 정책을 발표했습니다.

Kakao SDK는 UserDefaults를 사용하므로 해당 정책에 영향을 받습니다.

이에 따라 Kakao SDK for iOS(이하 iOS SDK)와 Kakao SDK for Flutter(이하 Flutter SDK)에 개인정보 보호 목록(PrivacyInfo.xcprivacy ) 파일을 제공합니다.

자세한 내용은 아래와 같습니다.

제공 일시

  • 2024년 3월 22일

상세 정보

  • iOS SDK, Flutter SDK에 개인정보 보호 목록(PrivacyInfo.xcprivacy) 파일 제공

  • iOS SDK

  • 2.22.0 버전 이상

  • KakaoSDKCommon 모듈에 포함

  • Flutter SDK

  • 1.9.1+2 버전 이상

  • kakao_flutter_sdk_common 패키지에 포함

필요한 조치

  • 최신 버전 iOS SDK 및 Flutter SDK를 사용하도록 앱 업데이트

  • 최신 버전 SDK 사용 시, 별도 조치 없이도 앱에 개인정보 보호 목록 정보가 반영됨

참고

언제나 더 좋은 서비스를 제공하기 위해 최선을 다하겠습니다.

감사합니다.




Hello, it’s Kakao.

Apple announced that apps or SDKs using “Required reason APIs” should declare the reasons in the privacy manifest from May 1, 2024.

Kakao SDK is affected by the policy because ofusing UserDefaults.

According to the policy, we provide a privacy manifest file(PrivacyInfo.xcprivacy) for apps using Kakao SDK for iOS(“iOS SDK”) or Kakao SDK for Flutter(“Flutter SDK”).

Details are below.

Release date

  • March 22, 2024

Details

  • iOS SDK and Flutter SDK provide the privacy manifest file(PrivacyInfo.xcprivacy).

  • iOS SDK

  • 2.22.0 version or higher

  • The privacy manifest file is included in KakaoSDKCommon module.

  • Flutter SDK

  • 1.9.1+2 version or higher

  • The privacy manifest file is included in kakao_flutter_sdk_common package.

What to do

  • Update the app to use the latest version of iOS SDK or Flutter SDK.

  • Using the latest version of the SDK, no actions are required to set the privacy manifest in the app.

Reference

We will always do our best to provide better service.

Thank you.

2개의 좋아요