카카오 로그인 JS SDK 버전 관련 문의

안녕하세요, 카카오 로그인을 이용하고 있는 유저입니다.
JS SDK 설치를 통해 기능 구현을 하고 있는데 해당 링크를 보다가 궁금한 점이 생겨서 글을 남깁니다.

다름이 아니라 오류 수정이나 기능 업데이트 마다 최신화되는 버전을
매번 추적해서 코드에 설치된 SDK 버전도 같이 업데이트 해주어야하는지 궁금합니다.

감사합니다:)

안녕하세요.

JS SDK v2 부터는 Subresource Integrity (SRI)가 지원되기에 v1과 같이 latest 버전은 지원되고 있지 않습니다.

때문에 번거로우시겠지만 최신화 되는 버전을 확인하고 업데이트 해주셔야 합니다.
현재는 이러하지만, 주요 기능 보안 업데이트에 대해 알릴수 있도록 방안을 마련하도록 하겠습니다.

좋아요 1

답변 감사합니다.

그럼 해당 링크를 수시로 방문해서 업데이트 여부를 추적해야하는 건가요?

네, 번거로우시겠지만 수시로 확인하셔야 하며 이는 운영정책상의 내용이기도 합니다.

운영정책(https://developers.kakao.com/terms/latest/ko/site-policies#user-obligation)
제1조(서비스 이용자의 의무)
1항 귀하는 소프트웨어개발키트(SDK)를 비롯하여 서비스를 통해 카카오가 제공하는 기능에 대한 버전 업데이트를 수시로 확인하여야 합니다.

좋아요 1